Невизуальная работа в СУБД MS Access 2010. Часть 1

(Работа представлена на конкурс к десятилетию портала «Компьютерные технологии для незрячих и слабовидящих».)
Дата публикации:31.08.2014
Twitter Facebook Vkontakte

Оглавление

Введение

Этот материал может служить базовым руководством по невизуальной работе в системе управления базами данных (СУБД) Microsoft Access2010 в связке с программой экранного доступа JAWS for Windows версий 13 или 14 Под управлением операционной системы Microsoft Windows 7.

Программа MS Access 2010 позволяет создавать базы данных и работать с ними, создавать на их основе такие объекты, как:

Программа может быть полезной для пользователей, которые ведут активную работу с большим количеством людей. Примером может быть работа массажиста, которому необходимо вести базу пациентов, а также председателей и секретарей первичных организаций и организаций ВОс, которые также ведут базу вступивших и выбывших из организации людей и которым часто приходится составлять отчёты о проделанной работе. Всё это можно делать с помощью программы MS Access.

1. Знакомство и запуск программы

Запустить программу можно из меню кнопки "Пуск", пункт "Все программы/Microsoft Office/Microsoft Access 2010".

При запуске программы курсор находится на вкладке "Создать", т.е. ленточное меню "Файл кнопка"/Создать вкладка", и JAWS проговаривает "Создать вкладка". Далее необходимо клавишей [Tab] дойти до списка, первый элемент которого будет "Новая база данных" (JAWS произнесёт "новая база данных, список"). Активируем этот элемент, нажав клавишу [Enter].

1.1. Интерфейс программы

Интерфейс программы MS Access 2010 состоит из следующих элементов:

Разберём эти элементы более подробно:

  1. Заголовок программы отображает имя программы и имя активной базы данных. Например: "DaTabase2: база данных (Access 2007 - 2010) - Microsoft Access". Прочитать заголовок: сочетание клавиш insert+T.
  2. Ленточное меню расположено под заголовком программы. Ленточное меню и Представление Backstage. Набор команд на вкладке "Файл" состоит из вкладок. Основные вкладки ленты: Файл, Главная, Создание, Внешние данные и Работа с базами данных. Команды ленты соответствуют объекту, активному в настоящее время. Например, если открыть таблицу в режиме "Таблица" и нажать кнопку "Форма" на вкладке "Создание" в группе "Формы", приложение MS Access создаст форму на основе активной таблицы. Иначе говоря, имя активной таблицы будет указано в свойстве формы. Также на ленте появляются так называемые контекстные вкладки. То есть вкладка появляется в определённом контексте. Например, если открыть объект в режиме "Конструктор", то на ленте появляется вкладка "Конструктор" и эта вкладка является активной. При нажатии клавиши [Alt] курсор будет находиться на этой вкладке. Ещё две контекстные вкладки - вкладки "Таблица" и "Поля" появляются при открытой таблице в режиме "Таблица". Ниже представлена таблица с описанием основных вкладок и возможными действиями в них.
    ФайлГлавнаяСозданиеВнешние данныеРабота с базами данных
    Создание новой базы данных.Выбор режима представления.Создание пустой таблицы в режимах "Таблица" или "Конструктор".Импорт или связывание внешних данных.Перенос некоторых или всех частей базы данных на новый или существующий сайт SharePoint.
    Открытие базы данных.Работа с буфером обмена: копирование, вставка и т.д.Создание отчётов, запросов, форм в режиме "Конструктор" или с помощью мастера.Сбор и обновление данных по электронной почте.Запуск редактора Visual Basic или выполнение макроса.
    Закрытие базы данных.Работа с текстом.Создание отчётов, запросов, форм на основе активной таблицы.Экспорт данных. Создание и просмотр отношений между таблицами.
    Параметры Access.Работа с записями: поиск, замена, фильтрация.Создание списка на сайте SharePoint, а также связанной с этим списком таблицы в текущей базе данных. Создание сохраненных операций импорта и экспорта. Показ или скрытие зависимостей объектов.
    Работа с записями: (обновление, создание, сохранение, удаление, итоги, орфография, дополнительно)Создание сводной таблицы или диаграммы.Запуск диспетчера связанных таблиц.Запуск архивариуса или анализ производительности.
    Работа со шрифтами: свойства, выравнивание шрифта.Создание запроса, макроса, модуля или модуля класса. Запуск архивариуса или анализ производительности.Перемещение данных в Microsoft SQL Server или базу данных Access (только таблицы).
  3. Область навигации содержит Область переходов, на которой отображаются все объекты MS Access. Область в левой части окна Access, предназначенная для работы с объектами базы данных.
  4. Строка состояния расположена в нижней границе окна программы. С помощью кнопок, расположенных на Строке состояния, можно переключать режимы объектов. Переход на строку состояния: многократное нажатие клавиши [F6]. Навигация по Строке состояния осуществляется клавишей [Tab].

1.2. закрытие существующей базы данных и создание новой

Для того Чтобы закрыть базу данных, не выходя из программы, необходимо выполнить команду ленточного меню "Файл/Закрыть", при этом текущая база данных закроется, и курсор переместиться на вкладку "Создать". Для создания новой базы данных можно воспользоваться несколькими способами. Воспользоваться пунктом выше, т.е. закрыть текущую базу данных. В окне программы воспользоваться сочетанием клавиш Ctrl+N. Курсор перейдёт на пункт "Новая база данных", по пути: ленточное меню "Файл/Создать". Выполняем этот пункт клавишей [Enter].

Соответственно, выполнив команду ленточного меню "Файл/Создать вкладка", в этом случаи необходимо клавишей [Tab] переместиться до элемента списка "Новая база данных" и выполнить его клавишей [Enter].

При создании базы данных создаётся файл баз данных "DaTabase" с расширением".accdb". В более ранних версиях Access до версии 2007 файл имел расширение "mdb".

Для того чтобы приступить к работе с уже существующей базой данных, необходимо запустить соответствующий файл "DaTabase.accdb", открытия этого файла можно произвести нажатием на нём клавиши [Enter] или в программе MS Access с помощью сочетания клавиш Ctrl+o вызвать диалог открытия файла, указать путь до файла.

При открытии файла базы данных курсор находится в Области переходов.

2. Работа с объектами базы данных

2.1. Объект "Таблица"

При первом запуске программы и выборе пункта "Новая база данных" откроется рабочая область в режиме "Таблица", но для удобства создания таблицы базы данных необходимо переключиться в режим "Конструктор".

Для перехода в режим "Конструктор" необходимо выполнить команду ленточного меню "Главная вкладка/Режим разделенная кнопка/Конструктор". Или в русской раскладке нажать сочетание клавиш Ctrl+Shift+.(русская точка).

Открывается рабочая область в режиме "Конструктор". Эта рабочая область состоит из строк и столбцов, где количество строк =N, а количество столбцов =3. Первый столбец содержит ячейки для заполнение заголовков полей будущей базы данных. Второй столбец - раскрывающийся список, который содержит в себе значение "тип поля". Выбор в этой ячейки типа поля относится к первому столбцу. В первом поле написали "ФИО" нажали клавишу [Tab] и перешли во второй столбец в ячейку с раскрывающимся списком типа поля. Здесь необходимо выбрать тип поля "текстовый", кстати, он по умолчанию и будет для всех записей.

Примечание: при перемещение курсора по списку JAWS не читает элемент под курсором. Чтобы узнать элемент под курсором, необходимо воспользоваться сочетанием клавиш insert+Tab или insert+стрелка вверх.

Для того чтобы изменить тип данных, можно нажать начальную букву названия типа. Например, в первом столбце конструктора написали фразу " адрес сайта", клавишей [Tab] перешли во второй столбец, JAWS произнесёт "текстовый". Для выбора типа "гиперссылка" нажмите букву "Г", тип изменится на "гиперссылка".

Тип поля определяется типом данных, которые содержит первый столбец. Поля могут содержать данные следующих основных типов:

Третий столбец в режиме "Конструктор" - это столбец описания данных, его можно оставлять не заполненным.

Внимание: заполненные ячейки первого столбца являются заголовками полей будущей таблицы базы данных.

После того, как все данные внесены,с помощью контекстного меню можно выбрать ключевое поле, он же первичный ключ. Если поместить курсор на поле "код",то при вызове контекстного меню, будет видно, что по умолчанию отмечено ключевое поле "счетчик". Для выбора другого ключевого поля необходимо выйти из контекстного меню, поместить курсор на поле, которое будет ключевым, вызвать контекстное меню и выполнить пункт "ключевое поле".

Ключевое поле - это поле, значение которого однозначно определяет запись в таблице. Ключевое поле должно быть уникальным, в поле не должно быть повторяющихся значений, ключевое поле (первичный ключ) не должно быть пустым. Ключевое поле необходимо для проведение связей между таблицами.

Ниже представлена таблица в режиме "Конструктор".

Имя поляТип поляОписание
КодсчетчикКод клиента
ФамилиятекстовыйФИО членов клиента

Навигация в режиме "Конструктор" осуществляется клавишей [Tab] и курсорными клавишами. Находясь в третьем столбце конструктора, следующее нажатие клавиши [Tab] переводит курсор на следующую строку конструктора.

Переход в режим "Таблица".

После того, как все данные заполнены в режиме "Конструктор", т.е. даны названия столбцов будущей таблицы базы данных, необходимо переключиться в режим "Таблица", для этого необходимо выполнить команду ленточного меню "Главная вкладка/Режим разделенная кнопка". Раскрываем её клавишей пробел и из списка выбираем нужный режим. Кнопка, "режим разделенная кнопка" находится и в следующих контекстных вкладках: конструктор, поле. Ещё один способ переключения режимов - использование строки состояния, перейти на которую можно по клавише [f6]. Её необходимо нажимать До тех пор, пока JAWS произнесёт "Конструктор, кнопка нажата", далее клавишей [Tab] переходим до кнопки "режим Таблица" и активируем её клавишей [Enter]. При этом программа предложит сохранить таблицу, соглашаемся, и нажимаем кнопку "Да".

Внимание: при переходе из режима "Конструктор", при первом нажатии клавиши [f6] курсор попадает в окно "Свойство поля", в этом окне можно задавать определённые свойства поля, такие как количество символов для текстового типа данных, форматирование, формат даты, маска ввода, условия отбора и другие свойства. Посмотреть текущий режим можно с помощью сочетания клавиш Ctrl+страница вниз.

2.2. Работа в режиме "Таблица"

После того, как переключились в режим "Таблица",строки первого столбца, заполненные в режиме "Конструктор", в режиме "Таблица" стали заголовками полей таблицы и размещаются слева на право.

Ниже представлена таблица в режиме "Таблица".

![код]![фамилия]

!1!Иванов

!...!...

Столбцы в таблице называются полями, а строки - записями, выше в таблице название полей указанно в квадратных скобках.

Создание полей таблицы в режиме"Таблица"

В режиме "Таблица" можно создать необходимые поля, выполнив команду ленточного меню "Поля вкладка/Другие поля" и выбрав необходимый тип поля. Например, если выбрать тип поля "имя", то в таблице вставятся следующие поля: [код], [фамилия], [имя]. Можно выбрать тип поля "телефон", тогда в таблицу будут помещены все поля, связаные с типами номеров телефонов, от домашнего до номера факса.

2.3. Навигация в таблице

При открытии таблицы курсор находится в верхней левой пустой ячейке, т.е. под заголовком первого поля. Клавишей [Tab] и Shift+Tab перемещаемся по ячейкам таблицы. В последней ячейке строки нажатие клавиши [Tab] переместит курсор на следующую строку таблицы. При этом значение в поле "код" автоматически изменится на единицу.

Примечание: автоматическое изменение значение в ячейках столбца "код" происходит в том случаи, если тип данных для этого значения выбран "счетчик" и в строке есть хотя бы одна запись.

При навигации по таблице так же можно применять и курсорные клавиши со стрелками. Для быстрой навигации по таблице используются клавиши навигации, [Home], [End], в начало и конец строки, эти же клавиши в сочетании с клавишей [Ctrl] перемещают курсор в начало и конец документа, т.е. в первую и последнюю ячейки, где первая ячейка - это левая верхняя ячейка, а последняя - правая нижняя ячейка. Сочетание клавиш Ctrl+стрелка вверх переводит курсор на первую запись текущего поля. Сочетание клавиш Ctrl+стрелка вниз переводит курсор на последнюю запись текущего поля.

2.4. Заполнение ячеек таблицы и работа с данными в ячейках

Заполнение ячеек в таблице СУБД MS Access напоминает заполнение таблицы в программе Microsoft Excel, т.е. три режима: " готово, ввод, и правка".

При вводе значений (записей) включается режим "ввод", зафиксировать запись можно нажатием клавиш [Tab], [Enter] и в том, и в другом случае курсор перемещается на одно поле вправо. При вводе записи в ячейку, которой уже была запись, прежнее запись удаляется. Для того чтобы отредактировать запись, не удаляя прежне значение, необходимо нажать клавишу [F2].

Работа с данными в ячейках

При большой записи, вся запись в ячейку не помещается и JAWS читает только часть записи. Для того чтобы отобразить всю запись, необходимо выполнить команду ленточного меню "Главная вкладка/Дополнительно кнопка с меню/ширина столбца/по ширине данных кнопка".

Клавишей [Alt] вызываем ленточное меню. Курсор находится на вкладке "Главная". Далее перемещаемся клавишей [Tab] до второй кнопки "Дополнительно кнопка с меню". Активируем её клавишей Пробел и в открывшемся диалоге клавишей [Tab] перемещаемся до кнопки "Ширина столбца". Активируем её клавишей [Пробел] и в открывшимся диалоге активируем кнопку "По ширине данных".

Ещё один способ изменения ширины поля - контекстное меню. Для этого необходимо сочетанием клавиш Ctrl+пробел выделить поле и в контекстном меню выполнить пункт "ширина поля", откроется диалог, описанный выше.

сортировка данных

Сортировка данных производится по возрастанию, по убыванию, от а до я, от я доа. Сортировку можно произвести как через контекстное меню, так и с помощью ленточного меню "Главная вкладка Группа Сортировка и фильтр".

Фильтр к данным в таблице можно применить через контекстное меню. Есть возможность фильтровать данные по определённому признаку, например, показать только мужчин или только женщин. Чтобы применить такой фильтр, необходимо поместить курсор в поле "Пол" или "Род", вызвать контекстное меню и выбрать пункт "равно" или "не равно". Чтобы показать только мужчин, необходимо выполнить пункт "равно мужской" или "не равно женский". Чтобы отменить фильтр, необходимо выполнить команду контекстного меню "Снять фильтр". Пункт "Снять фильтр" будет доступен в том случаи, если курсор находится в том поле, к которому применялся фильтр, соответственно, отмена необходимого фильтра должна производиться в том же поле, в котором и было произведено.

Если необходимо из большого количества данных найти какие-то точные данные, то в этом случаи лучше воспользоваться пунктом контекстного меню "Текстовые фильтры". Предположим, что надо отобразить все фамилии, начинающиеся на "МО", то в этом случаи выполним следующие действия:

  1. Вызываем контекстное меню.
  2. Раскрываем подменю "Текстовые фильтры".
  3. Выполняем пункт "Начать(С).
  4. В открывшемся диалоге в редакторе вписываем "Мо" и нажимаем кнопку "Ok".

В этом случаи в таблице отобразятся все фамилии, начинающиеся на "Мо". По такому же принципу работает точный фильтр в поле с числовыми данными, но при этом пункт "Текстовые фильтры" меняется на "Числовые".

диалог поиск и замена

Для поиска данных по таблице можно использовать диалог "Поиск и замена". Сочетанием клавиш Ctrl+Fвызовите диалог. Откроется диалоговое окно "Поиск и замена". Курсор будет находиться на вкладке "Поиск". В поле "Образец поиска" введите значение для поиска. При необходимости можно воспользоваться списком "Поиск", чтобы сменить поле для поиска или выполнить поиск по всей базовой таблице.

При необходимости в списке "Совпадение" выберите пункт "с любой частью поля". Это обеспечивает более широкий поиск.

В списке "Поиск" выберите пункт "все", а затем нажмите кнопку "Найти далее".

Клавишей [Esc] закрываем диалог, в результате курсор переместится к найденной записи. Для упрощения поиска в таблице для начала можно применить фильтр данных, воспользовавшись контекстным меню.

Удаление полей

Для удаления поля из таблицы необходимо выполнить команду ленточного меню "Поля вкладка/Удалить поле". Внимание: нельзя удалить поле, которое является ключевым и имеет связь с другой таблицей.

2.5. Создание новой таблицы и переход по таблицам

Для того чтобы создать новую таблицу в уже созданной базе данных, необходимо выполнить команду ленточного меню "Создание вкладка/Таблица" или "Конструктор таблиц". Для перехода с одной таблицы в другую используйте клавишу [F6]. Курсор перейдет в Область переходов, в список просмотра объектов, где курсорными клавишами с вертикальными стрелками выберите таблицу и активируйтекнопку клавишей [Enter]. Откроется выбранная таблица.

3. Объект "Ззапрос"

Для создания запроса необходимо выполнить команду ленточного меню "Создание вкладка, где клавишей [Tab] необходимо перейти до группы "Запросы" и выбрать один из вариантов создания запроса.

Рассмотрим работу с мастером запроса. Клавишей [Enter]вызываем диалог мастера запросов. На первом шаге необходимо выбрать нужный тип запроса.

Рассмотрим создание простого запроса.

3.1. Запрос по одной таблице

На втором шаге мастера выбираем необходимые поля, которые будут добавлены в результат запроса. При открытии второго шага диалога курсор помещается на первый элемент список, который показывает доступные поля. Второй элемент этого диалогового окна - это тоже список, который показывает выбранные поля. Следующие четыре элемента - кнопки. Первая кнопка, с помощью которой активируется выбранное поле для добавления в запрос, эта кнопка имеет знак ">"(больше). Следующая кнопка в диалоге имеет знак ">>"(больше больше), и её нажатие добавляет в запрос все доступные поля. Следующая кнопка имеет знак "<" (меньше), её нажатие удаляет выбранное поле из списка добавленных. Следующая кнопка имеет знак "<<" (меньше меньше), её нажатие удаляет все добавленные поля.

Для того чтобы добавить необходимое поле в запрос, выполним следующие действия: в первом списке помещаем курсор на нужное поле, а затем

Клавишей [Tab] перемещаемся до кнопки ">" (больше) и нажимаем клавишу [Пробел].

После того, как все необходимые поля добавлены и отображаются во втором списке, нажимаем сочетание клавишCtrl+Tab, чтобы перейти на кнопку "Далее". После нажатие кнопки "Далее" открывается третий шаг "Мастера запросов". На этом шаге можно указать имя запроса, перейдя клавишей [Tab] в соответствующее поле. Снова нажимаем сочетание клавишCtrl+Tab, чтобы перейти на кнопку "Готово" и активируем её.

3.2. Создание запроса на выборку данных по двум и более таблицам

Для создания таких запросов необходимо, чтобы таблицы были связанны меду собой. Предположим, что есть три таблицы. Таблица "ФИО", таблица "адреса" и таблица "телефоны". Сделаем запрос по этим таблицам на этот раз в режиме "Конструктор". Но для начала создадим связь между этими таблицами. Прежде чем связывать таблицы, необходимо закрыть все объекты, между которыми будет проводиться связь.

Примечание: для того чтобы закрыть текущий объект,применяем комбинацию клавиш Ctrl+w, при этом курсор помещается в Область просмотров, где можно выбрать другой объект этого же типа или выбрать объект другого типа.

Для создания связинеобходимо выполнить команду ленточного меню "Работа с базами данных/Схема данных". Откроется диалог добавления таблиц. Если этот диалог не открылся, то в открывшемся окне надо выполнить команду ленточного меню "Конструктор вкладка/Отобразить таблицу". Откроется диалог добавления таблиц. Теперь попеременно добавляем нужные таблицы, и нажимаем кнопку "Закрыть". Откроется окно с тремя таблицами и доступными полями. Чтобы создать связь между этими таблицами, выполним команду ленточного меню "Конструктор вкладка/Изменить связь". Откроется диалог, в котором необходимо нажать кнопку "Новая". В открывшимся диалоге надо указать левую таблицу, пусть это будет (ФИО). Указать правую таблицу, пусть это будет(адреса). Левое поле,(код) правое поле,(код). Тем самым мы указали, что поле "код" в таблице "ФИО" связано с таблицей "адреса". Поле "код" таблицы "адреса" ссылается на таблицу "ФИО".

Примечание: тип поля "код" в таблице "адреса" должен быть "числовой".

Выбор таблиц и полей производится вертикальными стрелками, клавишей [Tab] осуществляется переход между списками таблиц и полей. После произведённого выборанажать кнопку "Ok". В следующем окне необходимо отметить флажки "целостность данных" и нажать кнопку "Создать". Сё, связь создана. Сочетанием клавиш Ctrl+W закроем окно "Схема данных", согласимся на сохранения изменений. По такому же принципу создадим связь междутаблицей "Телефоны" и двумя другими таблицами.

Примечание:связь между таблицами производится по первичным ключам,и первичные ключи должны быть сочетаемые. Так, если первичный ключ одной таблицы имеет тип "счетчик", то тип первичного ключа другой таблице должен быть"числовой". В нашем примере первичный ключ в таблице "ФИО" имеет тип счетчик, первичные ключи в двух других таблицах имеют тип числовой.

Теперь приступим к созданию самого запроса.

Примечание: перед созданием запроса закройте все таблицы, по которым будет создаваться запрос.

Для создание запроса выполним команду ленточного меню "Создание вкладка/Конструктор запросов". Открывается диалог добавления таблиц. Из списка таблиц выбираем поочередно нужные таблицы и нажимаем кнопку "Добавить". После того как все таблицы добавлены, нажимаем кнопку "Закрыть".

Открывается бланк запроса в режиме "Конструктор", курсор при этом помещается в первом столбце, в первой ячейки. Здесь можно сделать следующую запись: "ФИО.*". Данное выражение необходимо записывать без кавычек. Клавишей [Tab] переходим на второй столбец конструктора. Здесь аналогично первому столбцу указываем в верхней строчки данные второй таблице -"адреса.*". Клавишей [Tab] переходим на третий столбец. В нём можно указать наименование поля, например, таблицы "телефоны", поле "мобильныйТелефон", тогда в ячейки имя таблицы отобразится таблица, в которой это поле присутствует. Ячейка с именем таблицы находится ниже на одну ячейку. Перейти и посмотреть отобразившуюся таблицу можно стрелкой вниз.

Обратите внимание, что в ячейки "имя поля"имя таблицы указано в формате: "имя таблицы точка символ звездочка". В этом случаи в запрос будут включены все поля указанной таблицы.

Далее выполняем команду ленточного меню "Конструктор вкладка/Выполнить". Запрос будет выполнен и его результат откроется для просмотра.

Если в запрос необходимо добавить данные из другой таблице, то в режиме "Конструктор"добавляем в бланк запроса необходимую связанную таблицу. Для этого выполним следующие действия. Если запрос закрыт, то в Области перехода на нужном запросе вызываем контекстное меню и выбираем пункт "Конструктор"; или открываем запрос с помощью сочетаний клавиш Ctrl+Enter. Запрос откроется в режиме "Конструктор". Выполним команду ленточного меню "Конструктор вкладка/Отобразить таблицу". Откроется диалог добавления таблиц. Курсорными клавишами с вертикальными стрелками выбираем нужную таблицу, клавишей [Tab] переходим на кнопку "Добавить", активируем её. Далее активируем кнопку "Закрыть".

При необходимости в запросе можно задать условие отбора. Для этого в режиме "Конструктор" клавишей [Tab] переходим на то поле, в котором необходимо произвести отбор. Курсорными клавишами с вертикальными стрелками спускаемся вниз до ячейки "Условие отбора". В этой ячейки вписываем то значение, по которому будет производиться отбор, например, название города. Если мы хотим отобразить в запросе только проживающих в Пятигорске, то в этой ячейке прописываем "Пятигорск", текст в условии отбора необходимо задавать в кавычках, хотя Access это сделает сам, но во избежание ошибки при автоматической расстановки кавычек лучше их расставлять вручную. Возьмем такой пример: нам необходимо отобразить в запросе проживающих в Пятигорске или в Кисловодске, для этого в строке "условие отбора" пишем "Кисловодск", а в строке "или" "Пятигорск", строка "или" находится ниже строки "условия отбора", но это маленький пример условия отбора.

Ниже представлены примеры таблиц и запрос по этим таблицам.

Таблица "ФИО".

[код][Фамилия][Имя][Отчество]
1АбрамовНиколайВасильевич
2БондарьПетрСергеевич
3КузнецовМихаилФедорович

Таблица "Адреса".

[код][адрес][город][область край][индекс][страна регион]
1Ул. ЧкаловаЕссентукиСтавропольский357600Россия
2ул. Ленина 1 кв. 10ПятигорскСтавропольский357100Россия
3ул. Гагарина 30 кв. 100КисловодскСтавропольский357200Россия

Таблица "Телефоны".

КодРабочий телефонДомашний телефонМобильный телефонНомер факса
1+8(928) 111-22-33

Таблица "запрос1".

ФИО.КодФамилияИмяОтчествоадреса.КодАдресГородОбласть, крайИндексСтрана или регионМобильныйТелефон
1АбрамовНиколайВасильевич1ул. Чкалова 5 кв. 5ЕссентукиСтавропольский35700Россия
2БондарьПётрСергеевич2ул. Ленина 1 кв. 10ПятигорскСтавропольский357100Россия
3КузнецовМихаилФедорович3ул. Гагарина 30 кв. 100КисловодскСтавропольский357200Россия

Обратите внимание, что в таблице "Запрос1" отображены все поля двух таблиц и одно поле из таблицы "Телефоны", это может быть не совсем удобно. В Access есть возможность скрывать поля. Для этого необходимо поместить курсор в то поле, которое необходимо скрыть, и выделить его сочетанием клавиш Ctrl+пробел, вызвать контекстное меню и выбрать пункт "Скрыть поле".

Однако запрос можно упростить и представить в более наглядном виде. Например, можно поля "Фамилия" и "Имя" объединить в одно поле. Давайте в созданном запросе объединим поля"Фамилия" и "Имя", а также поля "Город" и "Адрес". Чтобы это выполнить, откроем запрос в режиме "Конструктор", поместим курсор в первое поле ( туда, где мы писали "ФИО.*") И запишем следующее выражение:

ФИО.[фамилия] & " " & [имя]

Клавишей [Tab] перейдём во второй столбец и запишем там следующее выражение:

адреса.[город] & ", " & [адрес]

В выражении для объединения значений из полей "Имя" и "Фамилия" используется оператор (&), конкатенация. В выражении также используются кавычки, разделенные пробелом, который необходим для вставки пробела между фамилией и именем. В данном случаи символ (пробел) является константой в данном выражении. Если между двумя полями необходимо что-либо вставить, например, пробел, знак препинания, дополнительное значение требуется заключить в кавычки.

Ниже показан получившийся запрос.

Запрос2

Выражение1Выражение2мобильныйТелефон
Абрамов НиколайЕссентуки, ул. Чкалова 5 кв. 5|
Бондарь ПетрПятигорск, ул. Ленина 1 кв. 10|
Кузнецов МихаилКисловодск, ул. Гагарина 30 кв. 100|

Объединение полей ФИО можно произвести так, чтобы в вычисляемом полеотобразились фамилия и инициалы, тогда выражение примет следующий вид:

выражение1:[ФИО].[Фамилия] & " " & Left([Имя];1) & "." & Left([Отчество];1) & "."

где [фамилия] - имя поля;

"eft - функция LEFT, синтаксис которой Left ("stringexpr"; "n");

([имя]); - имя поля с которого будет браться инициал;

([отчество]) - имя поля с которого будет браться второй инициал;

символ (&) амперсанд - оператор конкатенация;

символы ""кавычки - между ними указываются константы (неизменяемые символы) такие, как символ " " (пробел) пробел или знаки препинания. В данном примере символ (.) точка, которая ставится после каждого инициала.

Цифра (1) указывает на количество символов, которые будут отображаться, т.е. первая буква имени и отчества.

При таком выражении запись в поле "Выражение1" примет вид: "фамилия инициал имени. Инициал отчества".

Обратите внимание, что при создании вычисляемого поля имя поля принимает вид (Выражение1, Выражение2) и т.д. Для изменения этого имени открываем запрос в режиме "Конструктор", что можно сделать из режима "Таблица", воспользовавшись сочетанием клавишCtrl+Shift+.(русская точка). Помещаем курсор в ячейку с выражением, клавишей [F2]переходим в режим редактирования, удаляем запись "Выражение1, выражение2" и вписываем до символа ":" (двоеточие) необходимое имя поля. Для первого поля пишем "ФИО:", для второго поля пишем "адрес_:", конечно же, пишем без кавычек. Обратите внимание, чтодля второго поля мы использовали знак подчеркивания, это было сделано для того, чтобы не возникало цикличной ссылки, так как в таблице "адреса" есть поле "адрес".

4. Объект "Отчёт"

Отчёт - это объект базы данных, который используется для отображения и обобщения данных.

Допустим, что у нас есть две таблицы "ФИО" и "Данные". В таблице "ФИО"записаны имена и фамилии пациентов, а в таблице "Данные" записаны данные пациента и количество массажных единиц. Ниже представлены два вида запроса, по которым будут проводиться отчёты.

Запрос 1

Фамилия_Имямассажные единицы
Иванов Иван1,5
Петров Пётр1,5
Николаев Николай1
Иванов Михаил1,5
Петров Николай3

Запрос 2

фамилиямассажные единицы
Иванов1,5
Иванов1,5
Николаев1
Петров3
Петров1,5

Из запросов видно, что некоторые пациенты имеют одинаковую фамилию, и в некоторых отчётах представленных ниже сделаем группировку по этим фамилиям.

4.1. Создание отчёта

Для создания отчёта выполним команду ленточного меню "Создание вкладка/Мастер отчётов". Запустится Мастер отчёта, который похож на Мастер запросов.

Первый шаг Мастера -выбираем источник данных для отчёта. Выбираем созданный нами запрос. На этом же шаге, как и в мастере запросов, добавим нужные поля в бланк отчёта. На этот раз нажмем кнопку ">>" (больше больше), т.к. в запросе у нас всего два поля. Нажатие этой кнопки добавляет все поля. Нажимаем сочетание клавиш Ctrl+Tab, пока не попадём на кнопку "Далее".

Второй шаг Мастера - группировка данных. На этом шаге можно выбрать поле, по которому будет производиться группировка. При выбранном поле группировки становится доступной кнопка "Группировка". Нажатие этой кнопки открывает диалог"Настройка уровня интервала группировки".

Третий шаг Мастера - сортировка данных. На этом шаге можно отсортировать данные по возрастанию или по убыванию. Если на предыдущем шаге была выбрана группировка, то на этом шаге будет доступна кнопка "Итоги". При условии, что в отчёт добавлено поле с числовым типом данных. Нажатие кнопки "Итоги" открывает диалог "Какие итоговые значения необходимо вычислить?". Перемещение по этому диалогу осуществляется клавишей [Tab] по флажкам, а сочетанием клавиш Ctrl+Tab выполняется переход на кнопку "Ok". В этом же диалоге есть две радио-кнопки, которые доступны только из-под JAWS-курсора.

Сочетанием клавиш Ctrl+Tab переходим на следующий шаг Мастера. Очень важный шаг, так как на этом шаге мы выбираем макет отчёта. Если создаётся простой отчёт без итогов, то список радио-кнопок выбора макета будет отличаться от списка радио-кнопок выбора макета для отчётов с группировкой и итогами. Для простого отчёта есть три варианта макета и ориентации:

Если в простом отчёте будут не большие данные, то целесообразно выбрать макет "табличный", если же какие то данные очень большие и явно будутбольше таблицы, то в этом случаи лучше выбрать макет выровненный, т. Е. все записи будут идти одна под другой.

Для отчётов с группировкой и итогами есть три варианта макета и ориентации:

Сочетанием клавиш Ctrl+Tab перейдём На последний шаг Мастера и дадим отчёту заголовок. Затем нажмём кнопку "Готово". Заголовок должен отражать суть отчёта, так как он будет размещён в верху первой странице, смотри раздел "Структура отчёта". Отчёт откроется в режиме предварительного просмотра. Закроем отчёт сочетанием клавиш Ctrl+w, т.к. для невизуальной работы он бесполезен. Или переключимся на режим "Макет" для работы с отчётом.

4.2. Работа с отчётом в режиме "Макет"

Для невизуальной работы отчёт необходимо открыть в режиме "Макет". Для этого в области перехода на нужном отчёте вызываем контекстное меню и в открывшемся меню выбираем пункт "Макет".

Навигация по отчёту в режиме макета

Навигация по отчёту в режиме "Макет" осуществляется клавишей [Tab]. При этом курсор будет перемещаться по всем разделамотчёта. В этом режиме возможно подвести итоги, сгруппировать данные, провести сортировку и фильтрацию по записям. Изменить шрифт, его размер, изменить другие свойства шрифта. Для того чтобы подвести итоги, необходимо поместить курсор в то поле, по которому будут подводиться итоги, и вызвать контекстное меню. В открывшемся меню выбрать пункт подменю "Итоги", раскрыв этот пункт. Станут доступны варианты вычисления итогов. Подведение итогов зависят от типа данных, по которым будут выполняться вычисления. Например, если тип данных "числовой", то будет доступен пункт сумма, среднее значение, и другие пункты, относящиеся к математическим действиям. Если тип данных "текстовый", то будут доступны пункты по подсчёту записей, по подсчёту значений. Для проведения группировки данных необходимо поместить курсор в то поле, данные которого будут сгруппированы, и в контекстом меню выбрать пункт "С группировать по приоритету".

Те же действия можно произвести, выполнив команду ленточного меню "Конструктор вкладка/Итоги". Сортировку, группировку и итоги можно проводить и подводить в процессе создания отчёта с помощью мастера,но в этом случаи придётся прибегнуть к JAWS-курсору. Так что лучше будет сначала создать отчёт, а потом в режиме "Макет" проводить с ним необходимые действия. Также нужно помнить, что кнопка "Итоги" в мастере будет доступна при условии, что в отчёте присутствуют одно или несколько числовых полей. Второе условие доступности кнопки"Итоги", - выбранное поле для группировки. Если пропустить шаг группировки, то на следующим шаге кнопка "Итоги" будет недоступной.

В режиме "Макет" можно изменять тип и размер шрифта данных, для чего необходимо открыть отчёт в режиме "Макет" и в ленточном меню выбрать вкладку "Формат". Перемещаясь по вкладке клавишей [Tab], можно изменять размер шрифта и его тип для каждого раздела отчёта или воспользоваться кнопкой "Выделить все", чтобы изменить шрифт для всего отчёта. Кнопка "Выделить все" находится во вкладке "Формат".

Для того чтобы невизуально просмотреть получившийся отчёт, его можно экспортировать в один из предложенных форматов. Для этого надо выполнить команду контекстного меню, подменю "Экспорт". В Области переходов на нужном отчёте вызываем контекстное меню, выбираем пункт "Экспорт подменю". В открывшимся меню выбираем нужный тип файла. Например, выберем пункт"Файл doc в формате rtf" нажмем клавишу [Enter]. В открывшемся диалоге, если необходимо, отметим флаг открыть целевой файл, укажем место экспорта и нажмём кнопку "Ok".

Благодаря этому незрячий пользователь может открыть файл отчёта,прочитать и провести с ним нужные действия: изменить шрифт, цвет, отредактировать или отформатировать, а затем вывести уже готовый,структурированный документ на печать.

4.3. Структура отчёта

Ниже в таблице представлена структура отчёта. Описаны разделы, которые присутствуют в отчётах.

разделрасположениеТиповые элементы
Раздел заголовкаОтображается один раз в верхней части первой страницы отчётазаголовок отчёта, эмблема, текущая дата
Раздел примечания отчётаОтображается ниже последней строки данных над разделом примечания страницы на последней странице отчёта
тоги отчёта (суммарные значения, счет, средние значения и так далее)
Раздел верхнего колонтитула страницыОтображается в верхней части каждой страницы отчёта.Заголовок отчёта, Номер страницы
аздел нижнего колонтитула страницы|Отображается в нижней части каждой страницы отчёта.|Текущая дата. Номер страницы
Раздел заголовка группыОтображается непосредственно перед группой записей.Поле, по которому выполняется группировка
Раздел примечания группыОтображается непосредственно после группы записей.Итоги группы (суммарные значения, счет, средние значения и так далее)

Ниже представлены примеры отчётов.

Простой отчёт, не сгруппированный и без итогов.

Отчёт по массажным единицам
	Фамилия_Имя	массажные единицы
	Иванов Иван	1,5
	Петров Пётр	1,5
	Николаев Николай	1
	Иванов Михаил	1,5
	Петров Николай	3
	17 августа 2014 г.	Стр. 1 из 1

Ниже представлен сгруппированный по фамилиям отчёт с итогами по массажным единицам. Группировка и итоги производились в отчёте в режиме "Макет".

Отчёт по массажным единицам 2
	фамилия	массажные единицы
	Иванов
	1,5
	1,5
	3
	Николаев
	1
	1
	Петров
	3
	1,5
	4,5
	8,5
	17 августа 2014 г.	Стр. 1 из 1

Ниже представлены отчёты, сгруппированные по фамилиям, и с подведёнными итогами с помощью мастера. В представленном ниже отчёте была отмечена радио-кнопка "данные и итоги", отмечен флажок "сумма" (sum).

Примечание: после активации кнопки "Итоги" необходимо переключиться на JAWS-курсор, и щелкнуть надпись "данные и итоги". Выбрать курсорными стрелками радио-кнопку "данные и итоги" и нажать клавишу [Enter]. Продолжить работу с мастером.

Отчёт по массажным единицам 3
	фамилия	массажные единицы
	Иванов
	1,5
	1,5
	Итоги для 'фамилия' =Иванов (2 записей)
	Sum	3
	Николаев
	1
	Итоги для 'фамилия' =Николаев (1 запись)
	Sum	1
	Петров
	3
	1,5
	Итоги для 'фамилия' =Петров (2 записей)
	Sum	4,5
	ИТОГО	8,5
	17 августа 2014 г.	Стр. 1 из 1

В представленном ниже отчёте была отмечена радио-кнопка "только итоги". Примечание: после активации кнопки "Итоги" необходимо переключиться на JAWS-курсор и щёлкнуть надпись "только итоги". Выбрать курсорными стрелками радио-кнопку "только итоги" и нажать клавишу [Enter]. Продолжить работу с мастером.

Отчёт по массажным единицам 4
	фамилия	массажные единицы
	Иванов
	1,5
	1,5
	Николаев
	1
	Петров
	3
	1,5
	17 августа 2014 г.	Стр. 1 из 1

5. Объект "Форма"

Создание и использование форм для ввода данных в таблицы базы данных MS Access2010. В MS Access можно вводить данные непосредственно в таблицу в режиме "Таблица". Но обычно для ввода данных в MS Access используют формы. Они ускоряют работу с базой данных. В форме отображаются поля одной или нескольких связанных таблиц или запросов. Форму можно использовать для ввода, изменения или отображения данных в таблицах или запросах.

Для создания формы необходимо выполнить команду ленточного меню "Создание вкладка/Мастер форм". Откроется знакомое окно мастера, в котором необходимо выбрать нужные поля из источников. При запуске мастера курсор находится на списке доступных полей. Для выбора другого источника перейдём на список, в котором можно выбрать запрос или таблицу, нажав сочетание клавиш Shift+Tab. Это раскрывающейся список, с помощью сочетаний клавиш Alt+стрелка вниз раскрываем его и вертикальными стрелками выбираем нужную таблицу или запрос. Отследить, на какой источник перешёл курсор, можно сочетанием клавиш insert+Tab или insert+стрелка вверх. Лучше всего начинать добавление полей из источника таблица "ФИО" начиная с поля "Фамилии", так как в форме отобразятся поля в том порядке, в котором вы их будете добавлять. После добавления всех нужных полей из всех необходимых источников нажимаем сочетание клавиш Ctrl+Tab для перехода на кнопку "Далее". На втором шаге мастера выбираем макет формы, на мой взгляд, лучше выбрать либо ленточный, либо в виде таблицы. Помощью сочетания клавишCtrl+Tab переходим на кнопку "Далее". На следующем шаге даем заголовок формы и нажимаем кнопку "Готово".

В результате форма будет выглядеть примерно так:

КодФамилияИмяОтчествоАдресГородОбластьКрайИндексСтранаРегионРабочийТелефонДомашнийТелефонМобильныйТелефон
1АбрамовНиколайВасильевичул. Чкалова 5 кв. 5Ессентукиставропольский35700Россия1-11-118-928-111-11-11
2БондарьПетрСергеевичул. Ленина 1 кв. 10ПятигорскСтавропольский357100Россия2-22-222-21-218-961-123-11-88
3КузнецовМихаилФедоровичул. Гагарина 30 кв. 100КисловодскСтавропольский357200Россия8-918-223-33-33

5.1. Работа с формой

С помощью формы можно добавлять данные во все таблицы сразу, например, если необходимо внести данные о новом человеке, то в этой форме необходимо заполнить все ячейки, для этого курсор перемещаем в конец файла. Нажатие клавиши [Tab] переведёт курсор в начало новой строки формы. С помощью клавиши [Tab] перемещаясь по ячейкам, заполняем их нужной информацией. Как результат, все занесённые данные отобразятся в соответствующих таблицах. Таким же образом можно изменять данные о человеке, например, девушка вышла замуж и изменила фамилию или переехала в другой город, у нее изменился домашний телефон и так далее. Вот с помощью этой формы можно изменить множество данных, расположенных в нескольких таблицах.

Для того чтобы удалить запись о конкретном человеке, необходимо в форме поместить курсор на строку с данными об этом человеке, выделить эту строку сочетанием клавиш Shift+пробел, вызвать контекстное меню и выбрать пункт "Удалить запись".

Изменение данных с помощью диалога "Найти Заменить"

Сочетанием клавиш Ctrl+H вызвать диалог "Найти Заменить".

Откроется диалоговое окно "Поиск и замена".

Курсор будет находиться на вкладке "Заменить".

В поле "Образец"введите значение для поиска.

В поле "Заменить на" введите значение для замены.

При необходимости можно воспользоваться списком Поиск в, чтобы сменить поле для поиска или выполнить поиск по всей базовой таблице.

В списке "Совпадение" выберите текущее поле.

В списке "Поиск" выберите значение "все", а затем нажмите кнопку "Заменить" или "Заменить все".

Клавишей [ESC] закрыть диалог.

6. О связях

Связи (или отношения) бывают:

Отношение "один-ко-многим"

Чтобы создать отношение "один-ко многим" в структуре базы данных, необходимо добавить в таблицу на стороне "многие" дополнительное поле, которое будет содержать значение первичного ключа связанной записи из таблицы на стороне "один".

Рассмотрим две таблицы: первая содержит фамилии членов ВОС (назовём её "ФИО"), а вторая содержит номера телефонов этих людей (назовём её "Телефоны"). Так как у человека может быть не один номер телефона,а несколько,то эта таблица будет на стороне "многие". Соответственно, таблица "ФИО" будет на стороне "один". В данном примере необходимо добавить ключевое поле на стороне "один" в таблицу на стороне "многие". Для этого в таблице "ФИО" выполним команду ленточного меню "Поле вкладка/Другие поля/Подстановка и отношения". Откроется диалог, на первом шаге которого необходимо будет выбрать из списка радио кнопок:

  1. Объект "Поле подстановки" получит значения из другой таблицы или другого запроса.
  2. Будет введён фиксированный набор значений.

Делаем выбор первой радио кнопки, нажав на ней клавишу [Enter].

На втором шаге Мастера выбираем необходимую таблицу или запрос и нажимаем на выбранной таблице клавишу [Enter].

На третьем шаге делаем выбор поля, которое станет в таблице "Телефоны" "внешним полем", делаем выбор поля "код", добавив его в список выбранных полей.

Четвёртый шаг Мастера - это сортировка данных. Выбрав сортировку полей, переключаемся на JAWS курсор и нажимаем кнопку "Далее".

Примечание: если не проводить сортировку на этом шаге, то данные будут отсортированы по первичному ключу таблицы на стороне "один".

На пятом шаге даем имя полю, флажок"Целостность данных" можно не отмечать, так как в связи "один ко-многим" это не работает. Переключаемся на JAWS-курсор и нажимаем кнопку "Готово".

Итог: в таблице "Телефоны" в дополнительном поле отобразились все номера телефонов для каждого человека, и образовалась связь "один ко-многим".

Примечание: путём подстановки в таблице на стороне "многие" в подстановочном поле получается, что-то типа запроса, так как в поле подстановки отображаются все данные, по одному человеку, и имеет вид раскрывающегося списка.

Отношение "многие-ко-многим"

Рассмотрим две таблицы: таблица "Заказы" и таблица "Продукты". Каждый заказ может содержать некое количество продуктов и один и тотже продукт может содержаться в нескольких заказах. Такая связь называется "многие ко-многим". Чтобы создать такое отношение, необходимо ключевые поля этих таблиц поместить в третью связующую таблицу.

Отношение "один-к-одному"

Обычно такой тип связи почти не используется, так как данные этих таблиц можно поместить в одной таблице.

7. Маска ввода

Маска ввода позволяет контролировать ввод данных в таблицу. И не только контролировать, но и упрощать процесс ввода. Маску используют в том случае, когда вводимые данные должны содержать определённные символы в некоторых позициях вводимой строки. Самым простым и ярким примером таких данных являются номера телефонов. Маска ввода должна обеспечить возможность вводить только цифры номера, а остальные символы (скобки вокруг кода города, дефис между цифрами номера) будут добавляться автоматически. Маска задаётся с помощью специальных символов.

Возьмём для примера таблицу "Телефоны" и поле "Домашний телефон". Для того чтобы установить маску ввода, необходимо открыть таблицу в режиме "Конструктор", поместить курсор в поле "ДомашнийТелефон", клавишей [F6] перейти в свойства поля, курсорными клавишами с вертикальными стрелками или клавишей [Tab] переместить курсор в ячейку "маска ввода". Для поля "ДомашнийТелефон" запишем маску в следующем формате:

!9\(999\)990\-00\-00;0;-

Где знак (!) означает, что маска ввода будет вводиться справа налево.

Цифра 9 означает, что пользователь может ввести цифру; цифра 0 означает, что пользователь должен ввести цифру. Подробно о знаках, использующихся в масках, смотри в таблице.

В этом примере символ (!)позволяет заполнять маску с право налево, благодаря этому, пользователь может внести номер телефона без кода города.

Пример маски ввода для заполнения поля "МобильныйТелефон":

"+7"000"-"000"-"00"-"00

При такой маске пользователю необходимо внести только цифры номера, кроме цифры 7. Знак (+), цифра 7 и другие символы будут подставляться автоматически. Маска ввода состоит из трёх частей, разделённых символом (;). Первая часть обязательная, в которой вводится числовой параметр, следующие две части необязательные. Здесь 0 означает хранить данные вместе со специальными символами, если хранение специальных символов не требуется, то вписывается цифра 1. Третья часть маски указывает на символ заполнитель. По умолчанию символ заполнитель - знак(_). Так, если не указать код города, то между круглыми скобками будет вставлен знак заполнитель.

Таблица символов маски ввода
ЗнакОписание
Пользователь должен ввести цифру от0 до 9. Знаки (+) и(-) не допускаются.
9Пользователь может ввести цифру от0 до 9. Знаки (+) и(-) не допускаются.
Пользователь может ввести цифру, пробел, знак "плюс" или "минус". Если ничего не ввести, будет вставлен пробел.
LПользователь должен ввести букву.
?Пользователь может ввести букву.
aПользователь должен ввести букву или цифру.
AПользователь может ввести букву или цифру.
&Пользователь должен ввести какой-либо знак или пробел.
cПользователь может ввести знаки или пробелы.
.,: ; / -Разделитель целой и дробной части, групп разрядов, значений дат и времени. Выбираемый знак зависит от региональных параметров Windowss.
>Все последующие знаки будут переведены в верхний регистр.
<Все последующие знаки будут переведены в нижний регистр.
!Маска ввода заполняется справа налево, а не слева направо.
\Знаки, следующие непосредственно за обратной косой чертой, отображаются без изменений.
""Знаки, заключенные в двойные кавычки, отображаются без изменений.

8. Некоторые горячие клавиши MS Access

Следующие горячие клавиши могут быть полезны при работе в среде СУБД MS Access.

КлавишиДействие
Ctrl+oОткрыть базу данных
Ctrl+NСоздать новую базу данных
CTRL+S или SHIFT+F12 или ALT+SHIFT+F2Сохранение объекта базы данных
F12 или Alt+F2Открытие диалогового окна Сохранение
F4 или Alt+СТРЕЛКА ВНИЗОткрытие поля со списком
CTRL+FВ диалоговом окне Поиск и замена открытие вкладки Поиск только в режимах таблицы и формы
Ctrl+HВ диалоговом окне Поиск и замена открытие вкладки замена только в режимах таблицы и формы
Shift+F4Поиск следующего вхождения текста, указанного в диалоговом окне Поиск и замена, при закрытом диалоговом окне (только в режимах таблицы и формы)
Ctrl+F6Переход между открытыми окнами, по порядку
Ctrl+W илиCtrl+F4Закрытие активного окна
Alt+F4Выход из Microsoft Access, закрытие диалогового окна или окна свойств
Ctrl+F2Вызов построителя
Ctrl+,(русская запятая)Переключение в следующий режим в таблице, запросе, форме, отчёте...
Ctrl+. (русская точка)Переключение в предыдущий режим в таблице, запросе, форме, отчёте...
EnterОткрытие выделенной таблицы или запроса в режиме таблицы, либо формы в режиме формы.
Ctrl+EnterОткрытие выделенной таблицы, запроса, формы, отчёта, страницы доступа к данным, макроса или модуля в режиме "Конструктор"
Alt+cПереход на вкладку создание
Ctrl+shift+стрелка внизРазвертывание подтаблицы для записи из таблицы
Ctrl+shift+стрелка вверхСвертывание подтаблицы

9. Область переходов

При запуске СУБД MS Access курсор находится в Области переходов, на объекте, который был активен перед последнем закрытием программы. Навигация по Области переходов осуществляется клавишей [Tab]. Если в кнопочном меню Области переходов отмечен пункт "все объекты Access", то при последовательном нажатии клавиши [Tab] курсор будет перемещаться по всем созданным объектам. Те или иные группы объектов можно сворачивать и разворачивать, переместившись на заголовок группы объектов, JAWS произнесёт его название и фразу "контурная кнопка, развернута". Свернуть группу объектов можно, нажав курсорную клавишу со стрелкой влево. Чтобы в Области переходов отображалась только одна группа объектов, надо раскрыть кнопочное меню. В раскрывшемся контекстном меню выбрать необходимый тип объектов и подтвердить выбор клавишей [Enter].

Послесловие

Доступность СУБД MS Access с помощью программы экранного доступа JAWS for Windows версий 13 или 14 оценивается, как хорошая. Некоторые элементы программы озвучиваются при дополнительных действиях. Например, при перемещении курсора по раскрывающимся спискам элементы списка не озвучиваются. Чтобы узнать на какой элемент списка переместился курсор, необходимо прочитать элемент под курсором нажатием сочетанием клавиш, Ctrl+Tabили ins+стрелка вверх. В окне мастера не озвучиваются кнопки добавления выбранных полей, JAWS озвучивает их просто "кнопка". С другой же стороны, в некоторых местах замечена чрезмерная болтливостьJAWS. Например, при перемещении по диалогу мастера JAWS постоянно читает все окно, т.е. о возможности выбора полей из запроса или таблиц и только в конце фразы произносит элемент под курсором. Чтобы немного исправить это положение, надо в параметрах программы отключить всплывающие подсказки. При навигации по таблицам, запросам и формам, замечено, что озвучивание заголовков полей происходит в том случаи, если в настройках JAWS,информативность пользователя установлено "начинающий" или "средний". При информативности "опытный" JAWS произносит только внесенные записи, а имена полей не произносит.

Описанные в руководстве действия с ленточным меню относятся к стандартному ленточному меню, без включения виртуальных лент JAWS.

Ссылки по теме



Распространение материалов сайта означает, что распространитель принимает условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2017
Rambler's Top100